The HuntingPA.com Outdoor Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
Hello all,
I just installed the Parker string suppressor kit on my enforcer. The directions state that the suppressor's should barely be touching the string when installed, but with mine I had to pull the string back slightly to install them (approx 1\16" to 1\8". I bottomed out the adjusters and still had to pull the string back to install them. Will this cause a problem ? The only thing I would know to do would be to cut a 1/16" or so off the rods.

Thanks in advance
 

·
Registered
Joined
·
28,459 Posts
I installed some on our Enforcer and the string laid right on the surpressors kind of making a shallow V in the rubber stopper. Shoots great, I still have a little rod to spare but not much. I actually loosened the rods then push them against the string til I got resistence then tighened it down.

Are you sure you put the mounting bracket on correctly? That would be my first check. I would take a pic of ours but the Enforcer now resides with my Dad 2 hours away.

I would NOT cut that rod period, aren't they fiberglass?

They may be correct as installed , I know ours pushes on the string some at rest and there is not much rod left over.
 

·
Registered
Joined
·
720 Posts
I thought my new Cyclone was lightly touching . I was having a hard time sighting it in. After I was done shooting I notice one of the rubbers was cracked open. When I loosened the one suppressors the string came forward when the pressure was released.
 
1 - 5 of 5 Posts
Top