The HuntingPA.com Outdoor Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
Ive been working on getting a yamaha warrior running thats been sitting for awhile. I got it running but its idling high and the exhaust pipe is getting red hot. Ive been trying to teach myself as i go because i dont know very much about working on motors and stuff. But i think im at a point where i could use some help. does anyone know what i might be able to do to try to fix these things. I tried adjusting the throttle but that didnt seem to do anything. I dont want to spend money taking it to a shop so if i can, i want to try to do things myself. Thanks in advance to anyone that might have some advise
 

·
Registered
Joined
·
9,646 Posts
Sounds like it could be several things.Major vacume leak,restricted exhaust,excessive lean condition.The carb is gonna have to come off and get a good soakin.Try shootin some carb cleaner in it for starters and check the exhaust and check for vacume leaks with it runnin by sprayin around the carb and intake with WD-40.
 

·
Registered
Joined
·
2,348 Posts
My guess is its running extremely lean. I bet if you pull the plug you will find it is white as well. If you still have the issue after giving the carb a proper cleaning (meaning every orifice, every jet gets cleaned completely), check the intake valves. They generally won't cause a high idle but they will make an engine run extremely hot if they are too close.
 
1 - 5 of 5 Posts
Top