The HuntingPA.com Outdoor Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
My TC omega recently started to have issues with the breech plug freezing up where I had to use socket wrench to remove. My standard load is T7 of 2f 100 grns, 260 grn bullet. The threads have been lubed. At range I cleaN after each shot. I put new breech plug in same issue. At 100 yds its a tack driver. Contacted TC. I have to send barrel back. Any one else have or had this issue.I have never exceeded 110 grns of powder.
Chuck
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
I was using the TC grease, however, I replaced the plug with a new one and on that one I used the teflon tape and the same thing hppened.
 

·
Registered
Joined
·
1,754 Posts
Everytime I remove breech plug I clean it well and apply a liberal amount of white lithium grease. Never had a problem with mine seizing.
 

·
Registered
Joined
·
889 Posts
I also use an Anti-Seize. I use Gorilla Grease.

But I bet you habe an additional problem. Take a 12 gauge bore brush. Chuck it up in a cordless drill and run it in reverse in your threads. I will bet you have some build up on those threads. Also check the small shelf at the bottom of those threads. And make sure you run the brush down far enough to clean that shelf.

A fellow told me about that the other evening and i did it to my rifles. I thought my rifle was really clean until I did that. Trust me on this one. I would bet you have some build up of crud in there. Especially if you are shooting T-7. Tom.
 
1 - 8 of 8 Posts
Top