The HuntingPA.com Outdoor Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,024 Posts
Discussion Starter · #1 ·
I have a Brute Force 750i with only 55 hours on it (and 145 miles - mostly low speed use when mowing). Over the weekend the belt light came on and is flashing. I know this happens at 100 hours to remind you to have service done but it doesn't flash. The atv won't go over 8 mph now. I guess it might need the belt replaced but I can't imagine that is so since I have so few hours. Does anyone have experience with this?

I don't really want to take it back to my local dealer since they tried to charge me $200 to put new tires on the rims.
 

·
Registered
Joined
·
1,126 Posts
Sounds like you somehow tripped the belt sensor switch, which puts you into a limp mode. That happened to a buddy of mine. Simple fix at a dealer or if you are mechanical enough you can search the web and find the fix and do it yourself! Also the light flashing may mean that you somehow stretched the belt and it may need adjustment/replacement.
Since you did not indicate that it has been recently submerged in water I would bet that is the case. Good luck!

P.S. Find a new dealer!
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter · #4 ·
Thanks guys. I am planning to take it to a dealer since I am afraid that if I take things apart that I won't be able to get it back together. I did not have it deep in water. I did use it to pull a 600 lb. brush hog through some rough terrain but I used low range. I doubt the belt is seriously damaged considering the limited amount of use. Thanks again.
 

·
Registered
Joined
·
2,144 Posts
First loose the $200.00 to mount the tires dealer.

Second like mentioned, Nyroc is an excellent site for the do it your selfers. They tell step by step procedures with photos of nearly every maintenance project.

http://nyrocatv.com/index.cgi

Pulling that 600 lb. brush hog, you may have glazed your drive belt and it's slipping on your drive pulley and sheave.

Is the quad still under warranty with so few hours?
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter · #7 ·
Thanks guys. It is not under waranty. I bought it new in the spring of 2008. I am pretty sure the waranty was for only 6 months.
 
1 - 7 of 7 Posts
Top