The HuntingPA.com Outdoor Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
974 Posts
Discussion Starter · #1 ·
Did anyone on here with a chevy silverado with the 5.3L ever have any issues with electrical problems? Such as lights dim,doorlocks go on and off while driving, battery just goes dead, traction controll locks in etc etc. If you did what did chevy do to fix it?
 

·
Registered
Joined
·
4,209 Posts
they are known for electrical problems. a buddys at works speedo and gas gauge never works. my uncles gas gauge along with most of his dash lights has issues also.
 

·
Registered
Joined
·
2,264 Posts
yo a bud of mine got new chevy p/u and i stopped at coffee shop to see him. walking in saw smoked windows thought nothing when i talked to him he said how do you like my new truck? nice you got smoked windows no we went out the darn thing was on fire. opened door burst into flams. he ended up with another new chevy...later
 

·
Registered
Joined
·
74 Posts
Mine had the same issue. Got in it one day and none of the electrical stuff worked. There is a bulletian out for a wring Harness near the E Brake. Take it in to the dealer and they should fix the issue under warranty.
 

·
Registered
Joined
·
170 Posts
GM had a recall on electrical issues a year or 2 ago. I think there may be a list of recalls on GM web site but I am not sure. I would not pay to have it repaired untill after I checked with GM.
 

·
Registered
Joined
·
974 Posts
Discussion Starter · #6 ·
Just bought the truck last thursday and it has been back 2 times. They picked it up with a flat bed today and I told them if it isn't fixed this time they agreed to buy it back. Has to be somthing simple and I know of 2 recalls on my truck that weren't done yet wich they are going to do. The one is the windsheild washer fluid heater wire wich can short out over heating the electrical system or even catch fire. The other is a passenger airbag module. Personally I don't giv a hoot what it is it just needs fixed or its time to go back to ford! Talk about frustrateing!
 

·
Registered
Joined
·
974 Posts
Discussion Starter · #7 ·
It was the ground from the battery. They replaced and all is fine. They fixed it and drove it for 2 days and everything was fine so I guess I'll give it another wirl!
 

·
Registered
Joined
·
3,157 Posts
Poor/dirty grounds cause a lot of 'funny' electrical problems. S-10's had ground straps between the rear of the engine heads & the firewall. People changing engines would forget to hook them back up and get all sorts of problems...

This spring I'll have to check where the grounds are on my new to me 2005 silverado...
 
1 - 8 of 8 Posts
Top