Polaris running hot - The HuntingPA.com Outdoor Community
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 10-22-2017, 03:43 PM Thread Starter
Regular Member
 
Join Date: Dec 2012
Location: pa, luzerne county
Posts: 1,668
Back To Top
Polaris running hot

Hey guys...2015 Hunter Sportsamn 570....only 110 hrs on it...just had it serviced...new oil, filter, anti freeze the whole schmere....took it on a new property I just joined...i noticed after about 15 minutes how hot it was getting under ny butt...drove fine for 2 hrs...put it back on trailer and turned it off. 5 minutes later tried to start it and it would not turn over,,,drove it howm and it started right up...must have cooled down...why was it running so hot? btw..it was the first quad ride i ever took on this machine...just bought it...
irishxc is online now  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 10-22-2017, 04:15 PM
Regular Member
 
Join Date: Jan 2003
Location: ..Harborcreek,Pa
Posts: 2,187
Send a message via AIM to 59Willys
Back To Top
Fan not turning on or your radiator is plug with mud.Not sure if it has a thermostat
59Willys is offline  
post #3 of 11 (permalink) Old 10-22-2017, 09:45 PM
The Man
 
Dogface's Avatar
 
Join Date: Mar 2005
Location: Sullivan County or SEPA
Posts: 9,305
Back To Top
If it was just serviced I'd make sure the anti freeze and oil were topped off properly.

There are two ways to be fooled. One is to believe what isn't true; the other is to refuse to believe what is true.
Dogface is online now  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 10-22-2017, 10:15 PM
Diehard Outdoorsman
 
Join Date: Nov 2015
Location: SW PA
Posts: 3,713
Back To Top
I'm no mechanic but my brother had a problem with a Rhino. He said here is a bleeder on the exhaust. His son hit something and ripped it off. Ended sucking up water up into engine some how. Had to rebuild engine because it kept running hot.
I know their different machines. Just saying what he said.
Laylow is offline  
post #5 of 11 (permalink) Old 10-23-2017, 10:34 AM Thread Starter
Regular Member
 
Join Date: Dec 2012
Location: pa, luzerne county
Posts: 1,668
Back To Top
Fan was running properly....will check the af and oil...i know that the overflow tank is full, i thought there should only be a 1/4 of anti-freeze in the overflow tank...
irishxc is online now  
post #6 of 11 (permalink) Old 10-23-2017, 11:00 AM
Hooked on HuntingPa
 
Join Date: Feb 2010
Location: Ne Pa.
Posts: 471
Back To Top
Dirt/dust, seeds in radiator, Happens when I ride in high weeds.

Good Luck, Stant
Stant is online now  
post #7 of 11 (permalink) Old 10-23-2017, 11:42 AM
The Man
 
Dogface's Avatar
 
Join Date: Mar 2005
Location: Sullivan County or SEPA
Posts: 9,305
Back To Top
Quote:
Originally Posted by irishxc View Post
Fan was running properly....will check the af and oil...i know that the overflow tank is full, i thought there should only be a 1/4 of anti-freeze in the overflow tank...
Your right. The AF should be pulled back into the system when the engine cools. That could indicate a blockage in the line like a bad thermostat.

Did you buy it from a dealer or an individual?

There are two ways to be fooled. One is to believe what isn't true; the other is to refuse to believe what is true.
Dogface is online now  
post #8 of 11 (permalink) Old 10-27-2017, 08:02 AM
Regular Member
 
Join Date: Jan 2003
Location: ..Harborcreek,Pa
Posts: 2,187
Send a message via AIM to 59Willys
Back To Top
Any up dates on your issue?
59Willys is offline  
post #9 of 11 (permalink) Old 11-04-2017, 03:49 PM Thread Starter
Regular Member
 
Join Date: Dec 2012
Location: pa, luzerne county
Posts: 1,668
Back To Top
Quote:
Originally Posted by 59Willys View Post
Any up dates on your issue?
Heat deflector...factory recall...didnt coat me a cent
Laylow likes this.
irishxc is online now  
post #10 of 11 (permalink) Old 11-05-2017, 06:42 PM
Regular Member
 
Join Date: Jan 2003
Location: ..Harborcreek,Pa
Posts: 2,187
Send a message via AIM to 59Willys
Back To Top
Cool !
59Willys is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The HuntingPA.com Outdoor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome