Wicked Ridge Invader XP Factory string issue - The HuntingPA.com Outdoor Community
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 10-12-2014, 10:16 PM Thread Starter
Hooked on HuntingPa
 
Join Date: Jan 2009
Location: Pa.
Posts: 320
Back To Top
Wicked Ridge Invader XP Factory string issue

If anyone is shooting the Invader check the clearance at the cam and the string,my cam was touching the string,the dealer checked it and found that the cables were wrong from the manufacturer,he got what was supposed to be a new set for the bow off the shelf measured them and found the package also marked wrong.he found a set that were the right length as stated by the 10 Pt. and installed.
ken66 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-17-2014, 09:28 PM
Part of the Community
 
Join Date: Nov 2007
Location: 2B
Posts: 186
Back To Top
Re: Wicked Ridge Invader XP Factory string issue

I have a Wicked Ridge Invader and after your post I checked my strings and limbs. I bought my Invader brand new in December. I have probably shot 50-75 shots out of it. When I checked it today the black part of the string was starting to fray at the cams exposing the string below. Also, upon closer inspection I noticed that the right limb had a small splinter and was starting to delaminate. I immediately called Wicked Ridge. They told me that some of the Invaders manufactured last fall were assembled with the wrong strings (too small). As a result of the incorrect strings the limbs are delaminating due to too much pressure. I shipped the front end to them today and they are replacing the limbs and cams free of charge. They are also giving me some free bolts due to my inconvenience since its hunting season. They told me they will fix it Monday and I should have the new limbs back by next Wednesday or Thursday. I'm glad I have my compound sighted in as a back up for this week.

2A/2B hunter
drabber13 is offline  
post #3 of 4 (permalink) Old 10-18-2014, 04:54 PM
Regular Member
 
Join Date: Sep 2000
Location: Pa
Posts: 1,841
Back To Top
Re: Wicked Ridge Invader XP Factory string issue

I had limb issues with mine also. They sent me a entire new front end and was back to shooting it within 3 days. No problems since.

The tree of liberty must be refreshed from time to time with the blood of patriots and tyrants.
Muzz is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 10-22-2014, 03:14 PM
Frequent Contributor
 
Join Date: Aug 2008
Location: eastern pa Berks
Posts: 579
Back To Top
Re: Wicked Ridge Invader XP Factory string issue

I just got my WickedRidge Invader back from TenPoint yesterday. They replaced the whole front end, my limbs were fracturing and the cams and axles were not right which wore out the string and cable, They did everything for FREE. Great Customer Service They are a really great company.
chopper57 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The HuntingPA.com Outdoor Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome